Process Order and Phone Order pages

Incident Report for Volusion

Monitoring

A potential resolution has been put in place, and initial results are encouraging. We will continue to monitor the situation closely. If store administrators still experience any difficulties loading the “Process Orders” or “Phone Orders” pages, we encourage them to contact our support team for further assistance.
Posted Mar 27, 2025 - 15:28 CDT

Identified

We have confirmed that this is a partial outage. We have also identified the issue with our load balancing partner and are working together with that partner to restore service.
Posted Mar 26, 2025 - 15:04 CDT

Update

We are continuing to investigate this issue.
Posted Mar 26, 2025 - 11:24 CDT

Investigating

Slowness has been reported when navigating to the Process Orders or Phone Orders pages in the admin area. We are currently investigating and will update you here as we learn more.
Posted Mar 26, 2025 - 09:19 CDT
This incident affects: Volusion Platform (Merchant Dashboard).