Rackspace Webmail Login
Incident Report for Volusion
Resolved
This incident has been resolved.
Posted Sep 09, 2024 - 12:39 CDT
Monitoring
Rackspace has indicated that a fix has been implemented and service has been restored.
Posted Sep 09, 2024 - 11:01 CDT
Investigating
Our 3rd party mail host Rackspace is currently experiencing issues with their webmail portal, and some of our users may have difficulty logging directly into their mailbox. If your email is hosted with Rackspace, or you have purchased your mailbox from Volusion, please visit Rackspace's status page https://status.apps.rackspace.com/ for further updates.

We will update this page when we can confirm the issue has been resolved.
Posted Sep 09, 2024 - 08:56 CDT
This incident affected: Volusion Platform (Email Services).