Intermittent Checkout Failure

Incident Report for Volusion

Resolved

We have a fix in place and can confirm that this incident is resolved.
Posted Oct 23, 2025 - 12:25 CDT

Identified

We have identified the cause of the order display issue and we are working on applying a fix.
Posted Oct 22, 2025 - 13:57 CDT

Investigating

We are currently investigating an intermittent issue affecting the Premium Checkout process. Some orders are failing to display in the admin dashboard however checkout and order submission is not affected. The immediate workaround for merchants to view affected orders has been to bulk update the order with an existing payment method. Our team is actively working to diagnose and resolve the root cause of the payment method failure.
Posted Oct 22, 2025 - 11:54 CDT
This incident affected: Volusion Platform (Merchant Storefronts).