Increase in payment declines with Stripe
Incident Report for Volusion
Resolved
This incident has been resolved.
Posted Nov 24, 2023 - 17:01 CST
Investigating
We have received notification from Stripe that they are currently seeing elevated latency and declines on transactions involving cards issued by JPMorgan Chase, as a result of an issue affecting the bank and external to Stripe.

You can check this status page for updates, or refer to Stripe status page here:
https://www.stripestatus.com/
Posted Nov 24, 2023 - 15:50 CST
This incident affected: Volusion Platform (Third-Party Services).