Rackspace Webmail Issues
Incident Report for Volusion
Resolved
This incident has been resolved.
Posted Jan 08, 2025 - 15:00 CST
Update
We are continuing to investigate this issue.
Posted Jan 08, 2025 - 14:59 CST
Investigating
We are receiving reports that Rackspace webmail is currently unavailable. Volusion webmail users may have difficulty logging in, using the interface, or long load times with their Volusion Rackspace hosted webmail. You can keep up with the incident with Rackspace's status page. https://status.apps.rackspace.com/
Posted Jan 06, 2025 - 14:27 CST
This incident affected: Volusion Platform (Email Services).