Webmail Login
Incident Report for Volusion
Resolved
This incident has been resolved.
Posted Nov 25, 2024 - 10:05 CST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 25, 2024 - 09:26 CST
Identified
Our 3rd party mail host Rackspace is currently experiencing issues with their webmail portal, and some of our users may have difficulty logging directly into their mailbox. If your email is hosted with Rackspace, or you have purchased your mailbox from Volusion, please visit Rackspace's status page https://status.apps.rackspace.com/ for further updates.

We will update this page when we can confirm the issue has been resolved.
Posted Nov 24, 2024 - 14:14 CST
This incident affected: Volusion Platform (Email Services).