Site Designer

Incident Report for Volusion

Resolved

This incident has been resolved.
Posted Nov 12, 2025 - 11:41 CST

Monitoring

A fix has been implemented and we will continue to monitor.
Posted Nov 12, 2025 - 10:33 CST

Investigating

We have received some reports from merchants regarding an issue with Site Designer. We will continue to investigate this and will provide an update when we have any new information.
Posted Nov 12, 2025 - 09:53 CST
This incident affected: Volusion Platform (Merchant Dashboard).