Some stores have reported downtime

Incident Report for Volusion

Resolved

This incident has been resolved.
Posted May 27, 2025 - 16:06 CDT

Monitoring

We have identified the fix and have implemented it. Stores are now back up and we are currently monitoring the fix.
Posted May 27, 2025 - 12:30 CDT

Investigating

We have received reports of downtime and are currently investigating. We will update you here as soon as possible.
Posted May 27, 2025 - 12:26 CDT
This incident affected: Volusion Platform (Merchant Storefronts, Merchant Dashboard).