Outage on Some Site Designer Stores

Incident Report for Volusion

Resolved

This incident has been resolved.
Posted Aug 28, 2026 - 17:03 CDT

Monitoring

Site Designer stores are back up and we are continuing to monitor uptime closely. We have not yet received an update from Google Cloud.
Posted Aug 28, 2026 - 15:08 CDT

Update

This outage is related to a network issue within Google Cloud data centers. We are working with Google to restore service.
Posted Aug 28, 2026 - 13:28 CDT

Investigating

Some Site Designer sites are currently down. We are investigating this issue and will provide updates as soon as possible.
Posted Aug 28, 2026 - 12:02 CDT
This incident affected: Volusion Platform (Merchant Storefronts, Merchant Dashboard).