Phishing Email Attempts
Incident Report for Volusion
Resolved
This incident has been resolved.
Posted Dec 01, 2021 - 15:04 CST
Monitoring
Volusion has identified a phishing attack (sent via WhatsApp text messaging) aimed at merchants attempting to steal login credentials (username / password) used to manage Volusion stores. The messages claim to be from an agent working with Volusion to boost visibility and viewing rates for merchants, and include a link that leads to a fake Volusion login page. If you have received a message of this type and have logged into the fake login page, your credentials have been compromised. We recommend resetting your password through your MyVolusion account.
Posted Sep 16, 2021 - 09:23 CDT