Intermittent Slowness or Errors on some Site Designer Stores

Incident Report for Volusion

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 05, 2026 - 18:42 CDT

Investigating

We are currently investigating an issue with intermittent slowness and errors affecting some stores using Site Designer. Our engineering team is actively tracing the cause to restore full performance as quickly as possible.
Posted Aug 05, 2026 - 16:25 CDT
This incident affects: Volusion Platform (Merchant Storefronts, Merchant Dashboard).