Rackspace Webmail Login
Incident Report for Volusion
Resolved
Our 3rd party mail host Rackspace has confirmed that the issue has been resolved. Further information and details on the issue can be found by visiting Rackspace's status page https://status.apps.rackspace.com/.
Posted Feb 18, 2023 - 20:23 CST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 18, 2023 - 20:21 CST
Identified
Our 3rd party mail host Rackspace is currently experiencing issues with their webmail portal, and some of our users may have difficulty logging directly into their mailbox. If your email is hosted with Rackspace, or you have purchased your mailbox from Volusion, please visit Rackspace's status page https://status.apps.rackspace.com/ for further updates.

Some users may be able to log into their mailbox at this alternative address
https://apps.rackspace.com

We will update this page when we can confirm the issue has been resolved.
Posted Feb 18, 2023 - 14:57 CST
This incident affected: Volusion Platform (Email Services).