Degraded Performance

Incident Report for Volusion

Resolved

This incident has been resolved.
Posted Jul 21, 2026 - 17:06 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 21, 2026 - 16:40 CDT

Investigating

We are currently investigating reports of periodic slowness and occasional page loading errors affecting a subset of stores built on Site Designer. Visitors to impacted stores may experience delayed load times. Our engineering team is actively tracing the cause to restore full performance as quickly as possible.
Posted Jul 21, 2026 - 16:18 CDT
This incident affected: Volusion Platform (Merchant Storefronts).