Unable to view Email spam prevention DNS records

Incident Report for Volusion

Resolved

This incident has been resolved.
Posted Feb 25, 2026 - 15:54 CST

Identified

We have received reports of merchants experiencing an issue when going to Design > Email Templates and clicking to view their email spam prevention records in the stores admin dashboard. When attempting to view the records, the message "Your store's domain registration is not complete." is presented incorrectly.

This is due to an issue that our third party email service is currently experiencing. For more details and update to date information on the issue visit the Mailgun status page here: https://status.mailgun.com/
Posted Feb 25, 2026 - 14:25 CST