Extreme Weather impacting some of our support services.
Incident Report for Volusion
Resolved
This incident has been resolved.
Posted Feb 03, 2023 - 09:32 CST
Identified
Due to extreme weather in central Texas, our Billing and Payments team will not be available for direct support.

For Billing related issues please email billing@volusion.com
For our merchant services support please email vmc@volusion.com.

Our team will respond to your requests as quickly as possible, and apologize for any inconvenience or delays this may cause.
Posted Feb 01, 2023 - 10:12 CST