Company Wide Meeting
Incident Report for Volusion
Resolved
Our company wide meeting has been concluded and our phone lines are operational again. Thank you for your patience.
Posted Oct 13, 2017 - 11:45 CDT
Identified
We are hosting a company-wide meeting between 9:15am CST to 10:45am CST. During this time our phone services will be unavailable, but our in-app messenger will remain open. We appreciate your patience along with providing us the ability to meet as a team.
Posted Oct 13, 2017 - 09:18 CDT