Some Sites Experiencing Downtime

Incident Report for Volusion

Resolved

This incident has been resolved and all sites should be functional.
Posted Jun 12, 2025 - 16:52 CDT

Monitoring

Sites are coming back up as Google Cloud recovers from the incident. We are continuing to monitor and you can track the progress of this outage at:

Pingdom Outage Tracker:
https://www.pingdom.com/outages/

Cloudflare Status Page
https://www.cloudflarestatus.com/

Google Cloud Platform
https://status.cloud.google.com/
Posted Jun 12, 2025 - 15:29 CDT

Identified

The issue has been identified. Google Cloud Platform, a major cloud hosting provider, is having a major outage, which is affecting other providers like Cloudflare. We apologize for the inconvenience. You can track the progress of this outage at the following sites:

Pingdom Outage Tracker:
https://www.pingdom.com/outages/

Cloudflare Status Page
https://www.cloudflarestatus.com/

Google Cloud Platform
https://status.cloud.google.com/
Posted Jun 12, 2025 - 13:52 CDT

Investigating

Some sites are currently experiencing downtime, we are currently investigating this issue and will post updates as soon as further information is available.
Posted Jun 12, 2025 - 13:12 CDT
This incident affected: Volusion Platform (Merchant Storefronts).