PayPal Outage
Incident Report for Volusion
Resolved
This incident has been resolved.
Posted Nov 24, 2023 - 23:29 CST
Investigating
We have received notification from PayPal that they are currently experiencing an outage that may impact customers ability to pay with PayPal/Venmo. We have not been able to reproduce issues placing and accepting orders, but we will provide further information as it becomes available. You can check this page as well as PayPal's status page here

https://www.paypal-status.com/product/production
Posted Nov 24, 2023 - 14:37 CST
This incident affected: Volusion Platform (Third-Party Services).