Unable to Create a Free Trial Stores
Incident Report for Volusion
Resolved
This incident has been resolved.
Posted Nov 21, 2021 - 16:11 CST
Investigating
We are aware that customers are unable to create free trial stores. We are currently investigating the issue and will provide additional information as soon as it's available.
Posted Nov 21, 2021 - 15:06 CST
This incident affected: Volusion Platform (Merchant Storefronts).